Стиль ссылок R1C1 в Excel

Адресация ячеек, когда в Excel установлен стиль ссылок R1C1. Абсолютные и относительные ссылки R1C1 в том виде, как они используются в формулах.

Смена стиля ссылок A1 на R1C1 в современных версиях Excel:

Файл >> Параметры >> Формулы >> Стиль ссылок R1C1 (установить галочку и нажать «OK»)

Абсолютные ссылки R1C1

Структура абсолютной ссылки R1C1:

  • R (первая буква от слова Row — строка) + номер строки;
  • C (первая буква от слова Column — столбец) + номер столбца.

Ячейка R1C1 соответствует ячейке $A$1, ячейка R2C2 — ячейке $B$2.

На изображении в отдельных ячейках записаны их абсолютные ссылки в стиле R1C1:

Соответствие абсолютных ссылок стиля R1C1 на изображении абсолютным ссылкам стиля A1:

Ссылка R1C1 Ссылка A1
R2C4 $D$2
R3C6 $F$3
R4C2 $B$4
R4C4 $D$4
R6C5 $E$6
R7C3 $C$7

Обратите внимание, что в ссылках стиля R1C1 сначала указывается номер строки, а в ссылках стиля A1 — буквенное обозначение столбца, а номер строки — на втором месте.

Относительные ссылки R1C1

Относительные ссылки R1C1 в Excel формируются следующим образом:

  • RC — относительная ссылка текущей ячейки на саму себя.
  • R[2]C — относительная ссылка на ячейку, расположенную на 2 строки ниже текущей ячейки.
  • RC[2] — относительная ссылка на ячейку, расположенную на 2 столбца правее текущей ячейки.
  • R[4]C[3] — относительная ссылка на ячейку, расположенную на 4 строки ниже и на 3 столбца правее текущей ячейки.
  • R[-4]C[-3] — относительная ссылка на ячейку, расположенную на 4 строки выше и на 3 столбца левее текущей ячейки.

На следующем изображении в ячейках указаны относительные ссылки, которые используются для обращения к ним из текущей ячейки — R4C4 ($D$4):


Стиль ссылок R1C1 в Excel используется значительно реже, чем стиль A1.

Иногда, с большими таблицами бывает удобнее работать при использовании стиля R1C1, при котором столбцы обозначены числами, а не составными буквенными индексами.

Стиль ссылок R1C1 может облегчить работу с формулами. Допустим, в 20 строке таблицы необходимо по нескольким столбцам вычислить итоговую сумму со 2 по 19 строку. Тогда в 20 строке по всем задействованным столбцах формула будет одинакова: =СУММ(R[-18]C:R[-1]C).

Добавить комментарий

Ваш комментарий будет опубликован после прохождения обязательной модерации. Исходящие ссылки не допускаются. Время модерации составит от нескольких минут до нескольких часов в зависимости от времени суток и занятости модератора.